Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » Unable to access Weblogic Mbeans (Oracle Fusion Middleware 12c, BAM server 12c, Windows 10)
icon5.gif  Unable to access Weblogic Mbeans [message #661511] Wed, 22 March 2017 05:16
Messages: 1
Registered: March 2017
Junior Member

I am trying to deploy my application for BAM server in Oracle Event processing Visualizer. These are the steps that I have followed:

1. Download BAM server libraries.
2. Setup in system as per the commands given on the oracle website.
3. After successful setup, start Weblogic using startWeblogic.cmd and then start NodeManager.

I am able to setup everything successfully and I can perform operations on servers as well. However, now I want to access weblogic domain runtime mbeans. I have followed the steps given in this link - https://docs.oracle.com/cd/E21764_01/web.1111/e13728/accesswls.htm#JMXCU150

So, now the problem is that it works fine and gives the Mbean information when I run it from JDeveloper. But when I deploy the code in the OEP server, the JMX connection fails with Timeout exception. Also, on JDeveloper, it works only for weblogic running on localhost and not for remote IP address.

Till now, I have tried the following things:
1. Made the classpath for JDeveloper and OEP server exactly same to make sure that this error is not because of missing libraries.
2. Tried with OIIP and RMI protocols, no luck as it says that user weblogic is denied. I tried adding boot.properties for this issue but still no help.

What am I doing wrong? How to make remote connections for accessing Weblogic Mbeans? I have been looking into this from last 3-4 days but still no help from any of the solutions given on different sites.

Thanks in advance!!
Previous Topic: application access problem
Next Topic: Oracle Reports installation --> RCU problem
Goto Forum:

Current Time: Wed Aug 17 15:35:34 CDT 2022