Home » Server Options » Streams & AQ » Problem due to deletion records from OBJ$ table
Problem due to deletion records from OBJ$ table [message #75757] Fri, 10 December 2004 01:20
Koushik Chandra
Messages: 3
Registered: December 2004
Junior Member

  While cleaning up streams from source database,we have found some rules and stream queue name was still present, so we tried to delete those records from obj$ table, but by mistake we have deleted all records from obj$ table related to streams.Actually we executed the following sql statement:


For this fault some problem arrise.After this we have found lots of SYS owner objects (VIEW,PACKAGE,TYPE) are become invalid.This situation happened in a remote database.For this remote database there is missing a TYPE "AQ$_JMS_STREAM_MESSAGE".

We have created a dummy database in local and executed the same delete statement, and after this We have executed (after shutdown immediate & startup migrate)catpatch.sql & (after shutdown immediate & startup) utlrp.sql but still there are some objects exists invalid.

e.g. one object is "_DBA_APPLY_ERROR" which is invalid.While I have tried to open the table "APPLY$_ERROR" for this view it showing an error message "ORA-00600: internal error code, arguments: [[kkdlusr1]], [[30813]], [[]], [[]], [[]], [[]], [[]], [[]]"

We are using ORACLE and Windows XP for our work.

Now please tell me what is it`s remedy.

Thanks in advance.

Koushik Chandra.
Previous Topic: Oracle Streams - When did the last apply process happen?
Next Topic: capturing queries
Goto Forum:

Current Time: Thu Aug 18 08:08:06 CDT 2022